Can't properly configure enconders to relative

Hi there, I’m trying to configure my enconder in Relative mode to contro,l AUX sends on my 1010 bluebox eurorack mixer. I’m using the “Encoder Mode” block on the Init tab and, according to the MIDI monitor it is sending 63 and 65 values, but my mixer continues interpreting those values as absolute values. Can someone point me on the right direction? Thanks!

Does the Bluebox support relative encoders? It’s something that a device needs to support.

Last I checked, 1010 boxes did not support relative mode.

What would you like to control? Multiple parameters on the bluebox without value jumps? Such thing can be configured on encoders. If you can describe your use case in a bit more detail, happy to help.

1 Like

Thanks for the prompt answers :slight_smile: I’d like to map aux sends to external effects, so that they don’t jump to zero whenever I touch them. I wish they’d just pick up where the current send values are. Thanks again. Best wishes and keep up the great work, your creatios really rock!

Hi [kertikristof! Any news on this? I’m preparing a live set for the next few weeks and could really use the help getting the encoders to work with the bluebox. Thanks!

Just reading through the manual for the Bluebox. It does not send out any MIDI values so there’s no way to keep the Bluebox and an external controller in sync. However, if your goal is to always use the external device to control the parameter then, bi-directional MIDI is moot.

So, you can enter MIDI Learn Mode on the Bluebox then navigate to the page and control you want to map. Tap the parameter then wiggle the Grid knob you want to use to control it. Rinse and repeat for each Bluebox parameter you want to control.

Out of the box, Grid will self assign its own channels and CCs. As long as you plug in and connect your Grids in the same way every time, they will always get the same channel and CCs assigned to each pot/fader/button etc.

It is also easy enough to setup static values for each element. But, let’s just try to get your MIDI learn setup first.

As you state "External FX Send’ and I don’t see this on any of the pages on the Bluebox, I assume you mean the ‘Track Page’ ‘Out 2’ parameter? Is this a second output that you’re using as an FX send?

Hi d4ydream and thanks for takinf the time :slight_smile:

I have all the faders, encoders and buttons on all the 4 pages of my 2 controllers already mapped on the bluebox. The problem is the lack of MIDI feedback and relative mode on the bluebox.

For instance, let’s say that I load a new project on the bluebox and one of the track gains is set to 6db instead of 0db. If I touch the corresponding encoder, it will jump back to 0 instead of picking it up from the 6db position where it was.

Since the bluebox doesn’t respond to relative changes (only absolute), I think the only way to achieve this would be with something that is usually descibed as “soft takeover” or “smooth takeover”, where the value only changes when the encoder reaches the current position.

I think some devices, such as the Faderfox UC4 and the Electra One MK2 are capable of this. I imagine that being so flexible and programmable devices the Intech controllers must have a script for this too…

Does this make any sense? :stuck_out_tongue:

Thanks again. Best!

The Faderfox EC4 for sure has this. It’s an internal soft takeover though from what I understand. This means that if you switch pages on the EC4, it saves the values from the page so that when you return, it won’t send values until you ‘catch’ the value that it was last at. This prevents parameter jumps. This is only for the EC4 internally and has no effect on the device it is controlling.

There is no way to overcome parameter jumps on a device that does not either:

  • Send its values out so that an external controller stays in sync with the device: bi-directional MIDI.


  • Has its own takeover mode so that it doesn’t respond to external values until the incoming value matches what the current machine value is.

It is an unfortunate shortcoming of a lot of devices. :frowning: Sadly, this appears to be the case with the Bluebox.